Resolved
This incident is now resolved โ
Please resume transaction processing if you haven't already.
Cause: Partner Outage
Monitoring
Disbursements previously impacting Mpesa in ETHIOPIA ๐ช๐น are now fully OPERATIONAL ๐ข.
Please resume transaction processing if you haven't already โ
We will continue to monitor performance before marking this incident as fully resolved.
Investigating
Transaction Performance: FULL OUTAGE